Exim Found to Have Yet Another Critical Flaw - Binary Defense

Threat Watch

Share on facebook
Share on twitter
Share on linkedin

Exim Found to Have Yet Another Critical Flaw

Exim is a popular open-source mail transfer agent that serves its purpose for Unix style operating systems such as Linux, Mac OSX, and Solaris, and is responsible for 60 percent of the internet’s email servers used for routing, delivering, and receiving messages. An important patch, Exim version 4.92.3, was released today in order to fix the issue affecting versions 4.92 through 4.92.2. The flaw was discovered by researchers and identified as CVE-2019-16928, which is described as a memory corruption issue in string_vformat defined in string.c file of the EHLO Command Handler component. If exploited, the flaw makes it possible for attackers to carry out DoS efforts and execute arbitrary code by making use of a specially crafted EHLO command. This is the third time this year that Exim has had to address critical flaws within their software and although they are usually quick to release patches, there is still a possibility for users to be affected.

ANALYST NOTES

Users should download and install version 4.92.3 as soon as possible. Exim also stated, “if you can’t install the above versions, ask your package maintainer for a version containing the backported fix. On request and depending on our resources, we will support you in backporting the fix.”

Contact Support

Please complete the form below and a member of our support team will respond as quickly as possible.