Break down the business value of Binary Defense services into dollars and cents

Threat Watch

Share on facebook
Share on twitter
Share on linkedin

Recently Patched Apache HTTP Server Vulnerability Exploited in Attacks

Organizations are being advised to ensure that their Apache HTTP servers are up to date, after it came to light that a recently patched vulnerability has been exploited in attacks. The vulnerability, tracked as CVE-2021-40438, is a server-side request forgery (SSRF) that can be exploited against httpd web servers that have the mod_proxy module enabled. An attacker can leverage this critical flaw using a specially crafted request to cause the module to forward the request to an arbitrary origin server. The issue was identified by the Apache HTTP security team while investigating a different vulnerability. It affects version 2.4.48 and earlier, and it was patched in mid-September with the release of version 2.4.49. “By sending a specially crafted request, attackers can force the mod_proxy module (if enabled) to route connections to an origin server of their choice — thereby allowing attackers to exfiltrate secrets (like infrastructure metadata or keys) or access other internal servers (which may be less protected than externally facing ones),” cloud services provider Fastly explained in a blog post published in October.

ANALYST NOTES

Organizations running Apache HTTP servers version 2.4.48 or earlier should patch to version 2.4.49 as soon as possible. This vulnerability could allow attackers to exfiltrate sensitive information, which could then enable them to compromise additional servers.

https://www.securityweek.com/recently-patched-apache-http-server-vulnerability-exploited-attacks